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10-IT-PART-B-Subject Specific Skills 

Part-B-Unit-1-Digital Documentation (Advanced)-(8m)-mb 

We have study in this unit: 

Chapter [1] : Applying Styles in a Document 

Chapter [2] : Adding Graphics in a Document 

Chapter [3] : Working with Templates 

Chapter [4] : Using a Table of Content ( TOC ) 

Chapter [5] : Using Mail Merge 

…………………………………………………………………………………………………………………………………………… 

Part-B-Unit-1-Digital Documentation (Advanced)-( 

Chapter [1] : Applying Styles in a Document 

Q[ ] Styles 

Ans : (i) A style is a Predefined Combination of various formatting features, like Font style, Colour, 

and size; that is applied to the selected text in a document to quickly change its 

appearance. 

(ii) When you apply a style, you can apply a group of formatting effects together in one simple 

step that makes the text effective and readable. 

Q[ ] Style Categories: 

Ans : There are five categories of Style available in Word 

[1]  Paragraph : This style is used to control all the aspects of a paragraph’s appearance, such as 

Text alignment, Tab stops, Line spacing, and so on. 

[2]  Character : The character style affects the character only, for example, it enables you to set 

the 

font and size of text, or bold and italic formats. 

[3]  Linked ( Paragraph and Character ): This style can be applied to both the Paragraph & 

Characters 

[4]  Table : The Table style is applied to change the appearance of tables, such as apply shading to 

the cells and format the border of the table. 

[5]  List : The list is used to select, format, and insert numbers or bullets in lists. 

………………………………………………………………………………………………………………………………………………………… 
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Applying Styles: 

Word provides various predefined styles to apply on the text in a document. 

There are two methods to apply styles on the selected text. 

[1] Style Groups or Style gallery 

[2] Style Pane 
 
 

[1]  Applying styles from Style Groups : 

You can apply built in Styles group of the Home Tab. 

(i) Open a blank document in Word and type the text you want. 

(ii) Select the text on which you want to apply a style. 

(iii) Move mouse pointer over the predefined styles in the Styles group of the Home Tab, 

to preview the effect of each style on the selected text. 

(iv) Click on a required Style, to apply it to the selected text. 
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[2]  Applying styles from Styles Pane : 

It is a floating and dockable Pane 

(i) Click on the Dialog box Launcher of the Style group of the Home Tab. 

(by me- ie Select Home tab, then Style Group, Dialog box Launcher ) 

(ii) Then Style Pane opens with variety of styled listed in it. 

(iii) Then select the text in the document on which you want to apply the style. 

(iv) Then select or click on any style from the Style Pane. 

(v) Then selected style will be applied to the text. 
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Importing a Style From Another Document : 

It means, you have created a style in one document & want to apply it to another document. 

This process includes 3 steps. 

[1] Creating New Styles in document with base formatting. 

[2] Importing Styles to another document 

[3] Applying the Styles 

Let us understand these steps with the help of an example. 

Step 2 : Importing Styles from another document 

(i) Now, open the document where you want to apply these styles, for example 

“Chapter1.docx” 

(ii) Click on the dialog box Launcher in the Styles group of the Home tab. 

(iii) The Styles pane opens. Click on the Manage Styles button from the bottom of the pane 

(iv) The Manage Styles dialog box displays. 

(v) Click on the Import/Export button given at the bottom of the Manage Styles dialog box 

(vi) The Organizer dialog box displays. 

(vii) Click on the Close File button on the right side of the dialog box. 

As soon as you click this button, the button changes to Open File button. 

Click on Open File button. 

(viii) In Open dialog box, click on the down arrow of the All Word Templates box. 

Select All Word Documents from the list. 

(ix) Locate the file from where you want to import new style for example, “magnet.docx”. 

(x) The styles of the file including the new styles that you have created will open on the 

right side of the Organiser dialog box. 

Practical: 
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Step 3 : Applying Styles 

(i) Click on Newstyle by holding the Ctrl key. 

(ii) Click on the Copy button and observe the styles being copied / imported to the “ Chapter.docx 

(iii) Close the Organizer dialog box. 

(iv) Now, you can apply the newly imported styles in your document. 
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Changing Syles: 

The styles you apply in document can be changed by using the Change Styles button 

on the Syles group of the Home tab. It has four options as listed below: 

[1]  Style Set : 

Style set is a combination of Title, Heading & Paragraph styles. It helps you format all the 

elements of the document in one step only, rather than formatting them separately. 
 

 
[2]  Colors : 

You can select a set of built-in colours themes for your document from the Colors list. 

You can also create your own colours theme by selecting the Create New Theme Colors 

option given at the bottom of the Colors drop-down list. 
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[3]  Fonts : 

Fonts list displays the built-in theme fonts that you can apply in the document. 

You can create a new theme font by clicking on the Create New Theme Fonts option at 

the bottom of the Fonts drop-down list. 

[4]  Paragraph Spacing : 

You can set the paragraph spacing of the whole document by selecting any option 

displayed in the Paragraph Spacing list. 

You can also set the paragraph spacing, according to your own requirement, by using 

the option Custom Paragraph Spacing in the Paragraph Spacing drop-down list. 
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Assessment : 

[A] Select the correct option 

(1) It is a predefined combination of various formatting features. 

a. Paragraph b. Style c. Font 

Ans : b. Style 

(2) The Styles group is available under the .......................... Tab. 

a. Insert b. Page Layout c. Home 

Ans : c. Home 

(3) The ..................... styles are used to control all the aspects of paragraph’s appearance. 

a. Character b. Paragraph c. Frame 

Ans : b. Paragraph 

(4) What operation do you perform in the current document to change a style ? 

a. Change Style b. Load Style c. Modify Style 

Ans : c. Modify Style 

[B] True or False 

(i) The styles pane opens on the left of the window, by default. - True 

(ii) The Styles pane is a floating or dockable pane. - True 

(iii) Page Styles include page size, margins, headers & footers, borders, and backgrounds - True 

(iv) You can not modify the predefined styles in word. - False 

(v) Style set is a combination of title, heading and paragraph styles. - True 

[C]  Answer the following questions. 

Q(1) What are Styles ? 

Ans : A Style is a predefined combination of various formatting features, like Font style, Colour & 

size, that is applied to the selected text in a document to quickly change its appearance. 

Q(2) What is the difference between Paragraph and Character styles ? 

Ans: (i) In Design, a Paragraph style is a collection of both Character and Paragraph 

formatting attributes that may applied to one or more paragraphs. 

(ii) A Character Style is a collection of Character formatting attributes that may be 

applied to one or more characters or words within a paragraph. 

(iii) A Paragraph Style may therefore contain one or more character styles. 

(iv) A Character Style should never be used for a full paragraph or multiple paragraphs. 
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Q(3) How can you apply a Style to the selected text ? 

Ans: (i) Select the text you want to format, or place your cursor at the beginning of the line. 

(ii) In the Styles group on the Home tab, click the more drop-down arrow. 

(iii) Select the desired style from the drop-down menu. 

(iv) The text will appear in the selected style. 

Q[4] How do you create a custom style? 

Ans: (i) Right-click the text (style name- by me) on which you want to base a new style. 

(ii) A mini toolbar appears, Click Style, and then click Create a Style. 

(iii) In the Create New Style from Formatting dialog box, gives your style a name 

and Click OK 

(iv) Your new style will now appear in the Styles Gallary. 

…………………………………………………………………………………………………………………………………………… 
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2.1  Introduction: 

Part-B-Unit-1-Digital Documentation (Advanced) 

Chapter – 02 : Adding Graphics in a Document 

* When you create a text document using Word, you may 

need to include some graphics, such as images, shapes 

and other drawing objects. 

* Graphics are added in the text documents to support the 

description provided in the text, images and pictures 

provide an immediate visual impact to the content, catch attention of the readers & stimulate 

better understanding of the content. 

………………………………………………………………………………………………………………………………………………………… 

* In Words, there are several ways to insert images in a Word document. 

[1] Inserting an image From a File 

[2] Inserting a Scanned Image 

[3] Inserting an image From Clip Art 

[4] Inserting an image Using Drag & Drop method 

[5] Inserting an image From the Clipboard 

……………………………………………………………………………………………………………………………………………………….. 

* Modify Images: 

Sometimes, you need to modify the inserted images in a document. For example, you 

want to adjust the size of the image, remove unwanted area from the image, rotate an image, add 

artistic effects, and so on. 

You can modify the images using options available in the Format tab that appears 

under the Picture Tools contextual menu. 

………………………………………………………………………………………………………………………………………………………. 

*Drawing Objects In a Document: 

In MS Word, Shaper is a drawing feature that helps you to 

draw different objects like banners, callouts, connectors, etc. with 

the help of these shapes, you can draw attention and 

provide impact to your message. INSERT  SHAPES 
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* Positioning Images in the Text: 

You need to set the position of an image with respect to the Text & other images while 

insertion it in a text document. The placement of Graphics is an important aspect in a word 

document. 

There are various methods to position an image in a document: 

(1) Wrapping Text 

(2) Arranging Images 

(3) Aligning Images 

……………………………………………………………………………………………………………………………………………………….. 

(1)  Wrapping Text: 

Wrapping text means, surrounding an image or drawing object within the text. The Wrap 

text options is used for this purpose, i.e. to wrap text around an image. 

It is available in Arrange Group of Format tab. Various options are available in the Wrap 

text drop-down menu. Some of them are listed as follows: 

(i)  In line with Text : This is the default option. This option places the image within the same line 

as that of the text. 

(ii)  Square: This option wraps the text around the square border of the image. 

(iii)  Tight: This option is used with irregular or round shapes to wrap the text around it. 

(iv)  Through: This option is similar to the Tight option as it also places the text around the image 

only. 

(v)  Top and Bottom: By selecting this option, the text will be placed on the top & bottom of image 

(vi)  Behind Text: The image is displayed behind the text ( like a watermark ) with this option. 

(vii)  In front of Text: This option displays the image over the tex. 

………………………………………………………………………………………………………………………………………………………… 

(2)  Arranging Images: 

While working with the multiple drawing objects, it may happen that one shape overlaps 

the other. MS Word provides two options- Bring Forward & Send Backword that enables you to 

change the order of the objects in your document. 

These options are available in the Arrange Group of the Format Tab. 

Bring Forward: This option brings a particular drawing object on the top of the other object. 

Send backword: This option sends the selected object behind the other object. 

……………………………………………………………………………………………………………………………………………………… 
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(3)  Aligning Images: 

You can align drawing images and objects Horizontally and Vertically in a document. 

To set the alignment, Select the image, Click on the drop-down arrow of the Align button Align in 

the Arrange Group of the Format Tab and select any one of the following options: 

(i)  Align Left: It horizontally aligns the left edges of the selected objects. If only a single object is 

is aligned to the left of the page. 

(ii)  Align Center: It horizontally centres the selected objects. If only one object is selected, the 

centre of the object is aligned to the centre of the page. 

(iii)  Align Right: It horizontally align the right edges of the selected objects. If only a single object 

is selected the object is aligned to the right side of the page. 

(iv)  Align Top: It vertically aligns the top edges of the selected objects. If only one object is 

selected, then the top edge of the object is aligned to the upper page margin. 

(v)  Align middle: It vertically centres the selected objects. If only one object is selected, then the 

centre of the object is aligned to the vertical centre of the page. 

(vi)  Align Bottom: It vertically aligns the bottom edges of the selected object. If only one object is 

selected, then the bottom edge of the object is aligned to the lower page margin 
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2.2  Inserting Images 

[1]  Inserting as Image From a File: 

(i) Click on the Insert tab and select the Picture button in the Illustrations group. 

(ii) The Insert Picture dialog box appears. 

(iii) Browse for the picture you wish to insert 

(iv) Choose the desired file and click on the Insert button. 

…………………………………………………………………………………………………………………………………………………………. 

[2]  Inserting Images from Clip Art: 

(i) Click on the Insert tab, in the Illustration group, click on the Clip Art option. 

(ii) The Clip Art gallery appears in the task pane on the right. 

(iii) Enter the keyword in the Search for, type the file name of the Clip Art. 

(iv) Click on Go button. In the displayed list of results, select the desired clip art 

to insert it in the document. 

Or 
 
 

 
Note : 

 
Click on the drop-down arrow next to an image in the task pane and select, 

Insert, Copy or any other options from the list. 

• We can insert a clip just by left click on the required clip. 

• Or right click on clip and then select insert. 
 

 
………………………………………………………………………………………………………………………………………………… 
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[3]  Inserting Images From a Scanner: 

(i) Select Start > Microsoft office > Microsoft Clip Organizer 

The Favorites – Microsoft Clip Organizer window appears. 

(ii) Click on the File tab. Then, select Add Clips to Organizer > From Scanner of Camera. 

(iii) Select the scanner device and resolution quality and then click on the Insert tab. 

(iv) Wait until the scanning is done and then click on the folder with your scanner name 

under My Collections section. You can see the scanned image in it. 

Close Microsoft Clip Organizer. 

(v) Now, open the Word document. In the Clip Art pane, click on the Go button. 

The scanned image appears. Click on the image to insert it into your document. 
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[4]  Inserting an Image using Drag an Drop Method: 

Drag and Drop means selecting an image from a particular location an dragging and 

dropping it in the document where required. The steps are as follows, 

(i) Open a word document and move the cursor to the location where you want to insert the image 

(ii) Now, locate the image on your computer, which you want to insert. 

(iii) Select the image and drag it in your document. The image will be inserted in the document. 

……………………………………………………………………………………………………………………………………………………….. 

[5]  Inserting an image from the Clipboard: 

(i) Open the document in which image already exists. 

(ii) Click on the image and press Ctrl+C to copy it. The image gets copied to the clipboard. 

(iii) Now, open the other document and place the cursor where you want to paste the image. 

(iv) Press Ctrl+V. The copied image is pasted in the document. 

………………………………………………………………………………………………………………………………………………………… 

2.3  Modifying Images: 

* Sometimes, we need to modify the inserted images in a document. For example, you may want 

to adjust the size of the image, remove unwanted area from the image, rotate an image, add 

artistic effects, and so on…… 

* We can modify the images using options available in the Format tab, that appears under the 

Picture Tools contextual menu. 

[1]  Resizing an Image: 

To resize an image, follow the given steps: 

(i) Select the image that you want to resize. You will notice four corner handles & four side handles 

(ii) Drag any Side handle in or out to shrink or stretch it in a direction. 

OR Drag any Corner handle in or out to make it smaller or bigger resp. Corner handles enable 

you to increase and decrease the size diagonally. 

…………………………………………………………………………………………………………………………………………………….. 

[2]  Cropping an image: 

Cropping means removing the unwanted area from an image. Steps are as follows, 

(i) Select the image that you want to crop. 

(ii) Click on the Crop button in the Size group of the Format tab. 

(iii) Eight Crop handles will appear. Drag a Side crop or Corner crop handle to the image. 

(iv) We can drag as much as you like. The Corner crop handles will crop the image diagonally. 

whereas using a Side crop handle, we can crop an image in horizontal or vertical direction. 
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[3]  Rotating an Image: 

To rotate an image or a shape, follow the given steps, 

(i) Select the image that you want to rotate. 

(ii) Click on the Rotate option in the Arrange group of the Format tab. 

(iii) A rotation handle appears. Bring the pointer on the rotation handle and drag it clockwise or 

anticlockwise to rotate the image or shape. 

 
 
 
 
 
 
 
 
 

 
……………………………………………………………………………………………………………………………………………………….. 

[4]  Using Picture Color tab: 

Using the options given under this tab, you can adjust the colour of the picture by adjusting 

the various settings, such as colour saturation percentage, colour tone percentage and recolour 

options like Grayscale, Black & white, Tan, etc. 

[5]  Using Artistic Effects Tab: 

You can easily apply some professional looking effects, such as Marker, Pencil Grayscale, 

Pencil Sketch, etc to the pictures by using the options given under the Artistic Effects tab. 

Note that you can apply only one effect to the picture at a time. 
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2.4  Drawing Object in a Document - Practical 

(i) Click on the Shapes button in the illustrations group of the Insert tab. 

(ii) A drop-down menu displays various options such as Lines, Basic Shapes, Block Arrows, 

Equation Shapes, Flowchart, Stars & Banners, Callouts, etc 

(iii) Move mouse pointer on Basic Shapes and click on any shape for example click on Smiley Face. 

(iv) The mouse pointer changes to a cross hair symbol ‘+’ drag it on a working area to draw a shape 

(v) The Format tab automatically appears on the Ribbon when you draw the shape. 

(vi) Select any shape style from the displayed list in the Shape Styles group. 

(vii) Click on the More drop-down menu to select and change the overall visual style of the shape. 
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* Changing the Properties of Drawing Objects: 

[1]  Changing Colour of a Drawing Object: 

(i) Select the drawing object that you want to modify. 

(ii) Click on the Shape Fill drop-down button in the Shape Styles group of the Format tab. 

(iii) Select the required colour and the colour of the shape will be changed immediately. 

(iv) You can also fill the object with a Picture, Texture or Gradient. 

(v) Again, click on the Shape Fill drop-down button, Select any option from Picture, Texture or 

Gradient and make the required changes. 

………………………………………………………………………………………………………………………………………………………… 

[2]  Changing Outline of a Drawing Object: 

(i) Select the shape that you want to modify 

(ii) Click on the Shape Outline drop-down button in the Shape Styles group under the Format tab 

(iii) Select any colour for the outline from the colour palette. 

(iv) You can modify the width of the outline of the shape by selecting the Weight option from the 

Shape Outline drop-down arrow. 

(v) Select the required style. 
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[3]  Grouping Drawing Objects: 

It is often convenient to group shapes together so that they can be treated as a single object. 

(i) Draw any three basic shapes in a document. 

(ii) Click on the Home tab. In the Editing group, click on the Select drop-down button & 

choose the Select Objects option from the drop-down list. 

(iii) Then, hold down the left mouse button to draw a box over the shapes. All the shapes in this 

box will be selected. or Press & hold Shift or Ctrl key while you select the objects. 

(iv) Now, right-click on the selected shapes that you want to group. A shortcut menu appears that 

have Group & Ungroup options. Select Group optios. 

OR 

Click on the Format tab and select the Group option from the Arrange group. 

Further select the Group option from the drop-down list. 

(v) You will now see that all the objects are grouped together. 

………………………………………………………………………………………………………………………………………………………… 

Assessment: 

Q[A] Select the correct option. 

(1) You can insert a picture in a document from the .......................... group of the insert tab. 

a. Arrange b. Symbols c. Illustrations 

Ans: c. Illustrations 

(2) ………………… is a collection of pictures or images that are available in Microsoft office gallery. 

a. WordArt b. ClipArt c. Picture 

Ans: b. ClipArt 

(3) You can fill colour in a shape by using the .................. in the shape styles group of the format tab 

a. Fill Shape b. Shape Fill c. Fill Color 

Ans: b. Shape Fill 

(4) ................................... Handles are used to resize an image diagonally. 

a. Corner Handles b. Side Handles c. both a & b 

Ans: a. Corner Handles 

(5) By using the ............................... dialog box, you can make changes in the picture properties. 

a. Format Picture b. Properties c. Image Properties 

Ans: a. Format Picture 
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Q[B] True or False 

(1) You can draw a shape on the document by selecting any shape from the insert tab. - True 

(2) The ‘Drawing Object Properties’ tab opens when you select an object. - True 

(3) Drawing objects can be grouped together so that they can be treated as a single object - True 

(4) Picture alignment options are available in the insert tab - False 

(5) You can bring any image in front of all the images by using the ‘Bring Forward’ option. – True 

Q[C] Answer the following questions. 

Q[1] List the different ways of inserting images in a document 

Ans: [i] Inserting an image From a File 

[ii] Inserting a Scanned Image 

[iii] Inserting an image From Clip Art 

[iv] Inserting an image using Drag & Drop method 

[v] Inserting an image From the Clipboard 

Q[2] Why do you group images ? 

Ans: By grouping Images, Shapes and other objects together, you can easily move or resize them. 

You can also copy and paste them all together, therefore saving you a lot of time and energy. 

Q[3] How can you wrap an image with text > 

Ans: To wrap text around an image: 

(i) Select the image you want to wrap text around. 

The Format tab will appear on the right side of the Ribbon. 

(ii) On the Format tab, click the Wrap Text command in the Arrange group. 

Then select the required text wrapping option. 

(iii) The text will wrap around the image. 

Q[4] What is Clip Art? 

Ans: Clip Art ( also write as clipart, clip-art), is a types of graphic art and are 

pre-made images used to illustrate any medium….. It is generally composed 

exclusively of illustrations group into insert tab. 
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3.1- Introduction: 

Part-B-Unit-1-Digital Documentation (Advanced) 

Chapter-03: Working With Templates 

* A Template is a predefined layout that contains sample content, themes, colours, 

font styles, background styles, etc. And gives an initial foundation to create a document. 

* By using a template, you can quickly create a new document. For example, if you want to create a 

business letter, you can use a letter template and modify only the required sections. 

…………………………………………………………………………………………………………………………………………………………. 

Creating a Template: 

[1] Using a Blank Template 

[2] Using an Existing Template 

Attaching a template to a document. 

 

…………………………………………………………………………………………………………………………………………………………. 

3.2- Using Built-in Templates: (practical) 

To use built-in template, follow these steps: 

(1) Click on the New option of the File tab. A gallery of templates will be displayed. 

(2) Click on the Templates option under the Available templates. 

(i) Select the required template. We will find the preview of the selected template in the 

preview pane present on the extreme right of the window. 

(ii) Select the Template radio button in the Preview pane and click on the Create button. 

(3) We can also choose from a wide range of many other templates present under the 

Microsoft Office Online Templates. 

(i) To choose a template from office.com Templates section, click on the template category, 

say ‘Event’ to open a gallery of templates. 

(ii) Select the required category from the gallery, say ‘Holiday Party Invitation’ 

and click on the Download button in the preview pane. 

(iii) Now, you can use the downloaded template to create your document. 
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3.3- Creating Template: 

A template can be created in word by saving a document as a .dotx or .dot file. 

There are two ways of crating a templates 

[1] Using a blank template [2] Using an existing template 

[1]  Using a blank template: 

To create with a blank template, follow these steps 

(i) Click on the new option in the File tab. 

(ii) By default, the blank document option is selected. 

(iii) Click on the Create button present on the extreme right task pane. 

(iv) A new document will open. Make the desired changes in the page layout, Like Margin settings, 

Orientation, Styles, etc. 
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[2]  Using an existing Template: 

To create a template using an existing template, follow these steps: 

(i) Click on the New option in the File tab. A gallery of templates will be displayed. 

(ii) Click on the New from existing option present under the Available Templates section. 

(iii) The New from Existing Document dialog box will open. 

(iv) Locate an select the template or document that you want as a base for your new template. 

(v) Click on the Create New button. 

(vi) A new document will be displayed containing the settings of the chosen base template. 

(vii) Make necessary changes ( if required ) and then click on the Save As option in the File tab. 

(viii) Specify the name for the template in the File name text box & select Word Template in the 

Save as type list box. 

(ix) Click on the Save button. 
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……………………………………………………………………………………………………………………………………………………. 

3.4- Attaching a Template to a Document: 

(i) Suppose, you have created a document in Word based on a particular template. 

(ii) Later on, if you want to change the attached template, you can do so by using the Add-Ins 

available for Word. 

(iii) Add-Ins are the additional programs that are used to extend the capabilities of MS Word 

by adding custom commands and specialised features. 

To use the Add-Ins, follow the given steps: 

[i] Click on the File tab > Options command. 

[ii] The Word Options window opens. 

[iii] Click on the Add-Ins option in the Left pane. 

[iv] The Add-Ins pane opens on the right. 

[v] Click on the drop-down arrow of the Mange option at the bottom & select Template option 

[vi] Click on Go. The Templates and Add-Ins dialog box opens. 

[vii] The template associated with the current document is displayed in the textbox under 

the Document Template section. 

[viii] Click on the drop-down arrow of the Manage option at the bottom & select Template option 

[ix] Click on Go. The Template and Add-Ins dialog box opens. 

[x] The template associated with the current document is displayed in the textbox under the 

Document template section. 

[xi] To change it, Click on the attach button. 
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[xi] The attach template window appears 

[xii] Locate the desired template file and click on the open button 

[xiii] The path to the selected template will be reflected in the textbox under the document 

template section. 

[xiv] Make sure to select the automatically update document style checkbox. Click on OK 

[xv] A new template will be attached to your document. 
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………………………………………………………………………………………………………………………………………………… 

3.5- Assessment: 

Q[A] Select the Correct option. 

[1] By default, the …………………….. option is selected when you click on the file > new option. 

a. Blank document b. Document 1 c. New document 

Ans: a. Blank document 

[2] A file saved with the extension .dotx / .dot is called a …………………………. 

a. Style b. Template c. Theme 

Ans: b. Template 

[3] Which option do you select in the ‘Save as type’ box to save a document as template? 

a. Template b. Word template c. text document template 

Ans: b. Word template 

[4] Which option helps in creating a template based on the existing template? 

a. Template from existing b. New template from existing c. New from existing 

Ans: c. New from existing 

Q[B] Fill in the blanks: 

[1] A............................... give an initial foundation to build a document. 

[2] ................................... is the default template for a Word document. 

[3] Clicking on the ................................ option displays the recently used templates. 

[4] A template can be created in word by saving a document with ……………. or .................. extension 

{ Hints : Normal dotm, Template, .dot, .dotx, Recent templates } 

Ans : [1] Template [2] Normal dotm [3] Recent templates [4] .dot, .dotx 
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Q[C] Answer the following questions. 

Q[1] What are templates? 

Ans: A template is a form, mold or pattern used as a guide to making something. 

Q[2] How can you create a document using a predefined 

template? 

Ans: (i) Click on the File tab, then click on New. 

(ii) Under Available templates, click New from existing. 

(iii) Click a template or a document that is similar to the one that you want to create 

and then click Create New 

Q[3] What are Add-Ins ? 

Ans: An add-in is a software program that expands the capabilities of bigger programs. 

It is a term commonly used by Microsoft and other platforms which have additional 

functions that can be added to primary programs. 
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4.1 Introduction : 

Part-B-Unit-1-Digital Documentation (Advanced) 

Chapter-04: Using Table of Content 

[i] You must have seen the Table of Contents page in your book that you refer to go to a particular 

chapter. 

[ii] The Table Of Content ( TOC ) consists of headings and subheadings of a book or document. 

[iii] It is a necessary index, generally available in long documents, books, drafts, etc. 

[iv] It includes titles or first-level headings, such as chapter names, and sometimes it even includes 

second-level headings and occasionally third-level headings. 

[v] A table of content act as a Map for the users. 

[vi] It allows them to find the information in the document using the chapter names & page 

numbers. 

[vii] A good table of contents has the following characteristics: 

1. It should be easy to read and simple to use. 

2. It should be organized and formatted properly. 

3. It must be accurate and easily accessible. 

4. It should be given after the title & copyright page. 
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Creating Table Of Contents: 

[1] To create a table of contents, you must use appropriate styles for the Heading in your 

document. 

[2] For example, Heading 1 style for the first level headings, Heading 2 style for the second level 

heading and so on. 

[3] You can also define the hierarchy of headings in a document if it contains multi-level headings 

[4] For example, you can categorise headings in different headings levels, such as 1, 1.1, 1.2, 2, 

2. 1,  and so on.. 

[5] When chapters or sections will be added or deleted, the numbering of headings levels will 

automatically change. 

[6] Word provides there method to create a table of contents in a document. 

(i) Using Inbuilt types 

(ii) Using the Manual Table option 

(iii) Using the Insert Table of Content option 

…………………………………………………………………………………………………………………………………………………… 

[1]  Using Inbuilt type: 

(i) Word lets you build an automated table of contents using the Table of Content option. 

(ii) It generates all the entries automatically as hyperlinks in the TOC. You can visit the heading 

by pressing the Ctrl key and clicking on the hyperlink. 

[2]  Using Manual Table Option: 

Another option in the Table of Contents submenu is Manual Table. This option allows us 

manually enter the headings and subheadings in the table of contents. 

* Click on the References tab and select the Table of Content option. 

* A submenu appears, click on the Manual Table option. 

A table of contents is inserted where you can manually enter the topics, sub topics, page numbers, 

etc. This is usually not a recommend method to insert a table of content, as the chances of errors 

while typing are higher. 

……………………………………………………………………………………………………………………………………………………….. 
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Using Insert Table of Contents Option: 

In case you want to make modifications in the default style of the table of contents, you 

can use the Insert Table Of Content option from the sub-menu of the Table of Content menu. 

* Click on ReferenceS tab and select the Table of Content option. 

* A submenu appears, Click on the Insert Table of Content option. 

* The Table of Content dialog box appears. 

……………………………………………………………………………………………………………………………………………………….. 

Customising The Table of Contents: 

In word, you can easily customise the table of contents as per your requirement using the 

Table of Contents dialog box. To customise the TOC, follow these steps: 

* Select the existing table of contents by clicking on the icon on 

the top-left corner. 

* Now, click on the References tab. Click on the Table of 

Contents drop-down arrow. Select the Insert Table of 

Contents option from the sub-menu. 

( It will replace the existing table of contents with new formatting. ) 

……………………………………………………………………………………………………………………………..…………………………. 

Maintaining A Table of Contents: 

Whenever you make changes to the text of a heading in the body of document or the page 

on which the heading appears, those changes will appear in the table of contents automatically 

whenever it is updated. 

You can perform some basic operation as listed below: 

* Updating a table of contents when changes are made to the document. 

* Deleting a table of contents. 

……………………………………………………………………………………………………………………………………………………. 
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4.3 Creating Table of Contents – (practical) 

Using a Table of Contents 

 
 
 
 
 
 
 
 
 

 
To create table of contents, follow these steps: 

(i) Make sure that the headings are styled consistently. For example, use the Heading 1 style 

for the chapter names, Heading 2 style for the topics, Heading 3 style for sub-topics, and so on 

(ii) In the document, position the cursor where you want to insert the TOC. Usually, a table of 

contents is inserted after the title page in a document. 

(iii) Click on the References tab and select the Table of Contents option. 

(iv) A submenu appears. Word gallery has two inbuilt types of table of contents, 

Automatic Table 1 and Automatic Table 2 Select any one of them. 

(v) A table of contents will appear in the document. 

* Let us we have a word file and in that, 

first page is Certificate, second page is keep blank for Table of Content & page number 3, 4, 5 

contains Chapter 1, Chapter 2 & Chapter 3 respectively. 
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Select Reference tab 

Click on Table of Contents from Table of Contents group 
 

Select 
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[2]  Using Manual Table Option: 

Another option in the Table of Contents submenu is Manual Table. This option is allows 

you manually enter the headings and subheadings in the table of contents. 

(i) Click on the References tab and select the Table of Contents option. 

(ii) A submenu appears. Click on the Manual Table option. 

A table of contents is inserted where you can manually enter the topics, sub-topics, 

page numbers, etc. This is usually not a recommended method to insert a table of contents, 

as the chances of errors while typing are higher. 
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[3]  Using Insert Table of Contents Option 
 

……………………………………………………………………………………………………………………………………………………. 

Selecting Levels of Headings: 

(i) Use the spin arrow of the Show Levels option to specify the hierarchy level of headings 

in your table of contents. 

(ii) By default, word uses three levels of headings as the hierarchy level. You can increase 

or decrease the value here. For example, select 2 by using the spin arrows. 

(iii) Only Heading 1 and heading 2 from your document will be inserted in the table of 

contents. 

……………………………………………………………………………………………………………………………………………………… 
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Customising the Table of Contents: 

In Word, you can easily customise the table of contents as per your requirement using the 

Table of Contents dialog box. To customise the TOC, follow these steps: 

(i) Select the existing table of contents by clicking on the icon on the top-left corner. 

(ii) Now, click on the References tab. 

Click on Table of Content drop-down arrow. 

Select the Insert Table of Content option from the sub-menu. 

( it will replace the existing table of contents with new formatting ) 

(iii) The Table of Contents dialog box appears. 

(iv) Click on the Modify button. The Style dialog box open. 

(v) Select an appropriate style for the entries in the TOC. 

(vi) You can click on the Modify button in this dialog box to open the Modify Style dialog box. 

(vii) Using the Modify Style dialog box, you can make changes in the style of the headings, 

font, font size, colour, Font effects such as bold, italic or underline. 

(viii) You can apply other formatting effects on the headings by using the Format button 

in the Modify Style dialog box. 

(ix) Click on the Format button an select any option from the displayed list for ex. Paragraph. 

(x) The Paragraph dialog box opens. 

(xi) Make the required changes and click on OK. 

(xii) Similarly, you can make changes in front of style by clicking on the Font option in the 

Format button drop-down list. 

(xiii) Click on OK to close Modify Style dialog box. Again, click on OK to close the Style dialog 

box. 

(xiv) At last, click on OK to close the Table of Contents dialog box. 

(xv) You will be prompted to replace the existing table of contents. Click on the Yes button. 

(xvi) The table of contents will be modified with the recent changes. 
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Select Format option 

which is at the bottom 

left corner then displays 

more options… 

Here also select 

Modify option 

then displays 

dialog box 

Modify Style 
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It is asking us what ever 

formatting we have done, do you 

want to replace it. Select YES 

button. 

Then displays Table of Content as 

per our formatting done 

 

 

 

 

Do required 

formatting 

and 

finally select the OK 

button 
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OR 

 
 
 
 
 
 

 

 

We have change the cyber crime in capital letter here. 
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Then Table of Content it automatically changes to capital 
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Then it deletes 

Table of 

content 
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Assessment: 

Q[A] Select the correct option. 

Q[1] What does TOC stand for? 

a. Term of Contents b. Table of Contents c. Table of Components. 

Ans: b. Table of Contents 

Q[2] Which tab has the ‘Table of Contents’ option? 

a. References b. Insert c. View 

Ans: a. References 

Q[3] You can specify the hierarchy level of headings in your table of contents by using the 

… .................................... subject. 

a. Set heading b. Set level c. Show levels 

Ans: c. Show levels 

Q[4] By default, word uses ............................. levels of headings as the hierarchy level. 

a. Two b. Three c. Four 

Ans: b. Three 

Q[B] Fill in the blanks. 

( Hints: Hyperlinks, Headings, Tab leaders, Title page, Sub-headings ) 

Q[1] The Table of Content (TOC) consist of …………..…………… and ............................. of a book. 

Q[2] Word generates all the entries automatically as ....................................... of a book. 

Q[3] Usually, a Table of Content is inserted after the ............................... in a document. 

Q[4] ................................ are the lines that join the topics and sub-topic to the page number. 

Ans : [1] Headings and Sub-headings [2] Hyperlinks [3] Title page [4] Tab leaders 

Q[C] Answer the following questions. 

Q[1] What is TOC ? 

Ans : A Table of Content, usually headed simply Contents & abbreviated informally as TOC, is a list, 

usually found on a page before the start of written work, of its chapter or section titles or 

brief descriptions with their commencing page numbers. 

Q[2] List any two Characteristics of a good TOC. 

Ans: 
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Q[3] How can you update an existing TOC ? 

Ans: We can update an existing TOC as follows: 

(i) Locate and click the table of content in the document. 

(ii) Right-click the table of contents and select Update field in the pop-up menu. 

(iii) In the Update Table of Contents window, select the Update entire table option. 

and click the OK button. 
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Part-B-Unit-1-Digital Documentation (Advanced) 

Chapter-5: Using a Mail Merge 
 

 

 



Page 54 of 
146 

 

 

 

 
data source for example: 

 

 

 
Sender’s Address 

Receipient Address 
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………………………………………………………………………………………………………………………………………………….. 
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Assessment: 

Select the Correct option: 

Q(1) The ................................... is the letter that you wish to send to multiple recipients. 

a. Main document b. Address label c. Address list 

Ans: a. Main document 

Q(2) A merged document is created by merging the main document with the .......................... fields. 

a. Address book b. Data source c. Merged document 

Ans: b. Data source 

Q(3) You can print multiple address .................... on a single sheet by using the mail merge feature 

a. Books b. Labels c. List 

Ans: b. Labels 

True of False: 

(1) The process of mail merge involves only two steps. - False ( it involves 3 steps) 

(2) You cannot edit any address label in a merged document - True 

(3) The data source is associated with the main document. -  True 

(4) You can find the Start Mail Merge option in the Mailing tab -  True 
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Answer th following questions. 

Q[1] What do you understand by the term Mail Merge ? 

Ans: (i) Mail merge is a technique to merge text ( main document, containing letter ) 

with addresses (data source) to create personalized letters. 

(ii) Mail merge is a feature within most data processing applications that enables 

users to send a similar letter or document to multiple recipients. 

(iii) It saves our time and effort of retyping the same letter over and 

over. Q[2] Name the documents that are combined while using the Mail 

Merge feature. 

Ans: A mail merge is used to create Letters, Labels, Envelopes, E-mail message & Fax distributions. 

There are 3 documents that are involved in the mail merge process: 

i. Main document 

ii. Data source 

iii. Merged 

document Q[3] Define the 

term data source. 

Ans: (i) A data source is the location where data that is being used originates from. 

(ii) It can be as simple as a file with rows and columns. Data source may be database. 

(iii) It is table or spreadsheet or a database storing details (fields) of the 

recipients. Q[4] What is the main document ? 

Ans: Main document: In a mail-merge operation in Word, this the document contains the 

main body of your letter, field names, and merge instructions. The basic information in 

the main document remains the same. 

Q[5] What are the main steps involved in Mail Merge? 

Ans: The mail merge process generally requires the following steps: 

(i) Create a Main Document and the Template. 

(ii) Create a Data Source. 

(iii) Defining the Merge Fields in the main document. 

(iv) Merging the Data Source with the main document. 

(v) Save / Print 
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10-PART-B-Subject Specific Skills 

Part-B: Unit-2-Electronic Spreadsheet (Advanced)-(10m)-mb 

Chapter[6] Analysing data in a Spreadsheet 

Chapter[7] Linking data and spreadsheets 

Chapter[8] Sharing and reviewing spreadsheet 

Chapter[9] Using Macros in a spreadsheet 

……………………………………………………………………………………………………………………………………………………. 

Part-B: Unit-2-Electronic Spreadsheet (Advanced) 

Chapter[6] Analysing data in a Spreadsheet 
 

…………………………………………………………………………………………………………………………………………………… 

6.1 Introduction (Theory) 

Consolidating Data: 

(1) Consolidating data means combining data from different sources into one place. 

For ex, you have a Sales data from four different zonal heads in four different worksheets. 

(2) In such a case, to analyse data, you need to collate everything into one worksheet. It will 

become a tedious and tiresome, time-consuming task, if you combine it manually, using the 

traditional way copying and pasting. 

(3) Excel provides the Consolidate feature that lets you collage the data with minimal efforts. 

(4) It selects the contents of the cells from several worksheets and maintain the collected data 

in a Master Worksheet. 

(5) Example : Let us consider a scenario where a sales manager of an automobile showroom 

wants to calculate the total car sales in the first quarter of years 2020 and 2021. 

The sales of the first quarter of both the years have 

been stored in separate worksheets with names 2020 

and 2021. 
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………………………………………………………………………………………………………………………………………………………… 
What-If Analysis Tools: 

(i) The What-If Analysis tools of excel allow you to use different sets of values in one or more 

formula to explore all the various results. 

(ii) By using these tools, we can do what-if analysis to analyse complex data or two different sets 

of data on the same subject. 

(iii) You can also specify a result that you want to formula to produce, and then determine of 

values will produce that result. 

………………………………………………………………………………………………………………………………………………………. 

Scenario Manager: 

(i) Scenario Manager is an important tool of Excel, 

which you use to test the ‘What-If, question. 

(ii) It enables you to manage and view data from 

different input values. 

(iii) For example, if you want to calculate the effect 

of different interest rates on an investment, 

you could add a scenario for each interest rate an quickly view the results. 

(iv) A scenario is a set of values that you enter in a worksheet to perform calculations. 

(v) You can easily create, edit and format different groups of values ( in form of scenarios ) and 

name them as per your choice. 

(vi) You can create as many as scenarios as you want and then compare them without changing 
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the values, manually. 
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* Then select ADD button 

* Then, This scenario is added 

* Then similarly create next scenario for next bank 
 

Then we will see all four bank scenarios as follows 
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To see the scenario of particular bank, for example SBI bank 

Select SBI scenario and then select SHOW button, then EMI changes as per SBI scenario 
 

 

 

Note: we can 

DELETE, EDIT, MERGE or SUMMARY the scenario 
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Then click on fx ( insert function ) 
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Select OK button then displays 
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(i)  In Set Cell 

Enter the address of cell, which we want to enter EMI how much we want to pay. 

(ii)  In To value 

Enter the How much EMI we want pay for example, 50,000 

(iii)  In By changing cell 

Enter the address of cell in which we want to see how interest rate if we 

choose the EMI is -50,000 
 

Select the required data and press OK button 
 

Then if we change Interest manually in this table, then EMI is also automatically changes. 
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First Select the required data by mouse 

Then select, Data Table option from What-If-Analysis  from  Data Tab 
 

Enter the Row input cell and Column input cell range by mouse, then select OK button 
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Then displays the result in each selected cell 
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Practical: 
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By default Solver option is not available in excel, so do the following procedure 
 

 

 

Click on GO button 
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Then Solver is gets added in excel 
 
 
 
 
 
 
 
 
 
 

 

Then insert formula as follows 
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Click on Solve button, we get as follows, 

 
 
 
 
 
 
 
 
 

 
After clicking add button in previous step 
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Finally click on OK button. 

…………………………………………………………………………………………………………………………………………. 

Assessment: 

Abstract Chapter : 1. Consolidating Data 

2. Creating Subtoal 

3. What-If Analysis ( In Data Tab) 

i. Scenario Manager 

ii. Goal Seek 

iii. Data Table 

iv. Solver ( it is not in Data Tab, for this use Addin ) 
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Q[B] Fill in the blanks: 

(1) A Scenario is a .......................... that you enter in a worksheet to perform calculations. 

Ans: Set of Values 

(2) It is good practice to use ..................... data while applying the subtotal command to it. 

Ans: Sorted 

(3) The ................ tools displays the result of applying formula to list of alternative values 

for variables. Ans: Data Table 

(4).......................... can process only one input value at a time. 

Ans: Goal Seek 

(5)...................... deals with equations with multiple unknown variables. 

Ans: Solver 
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………………………………………………………………………………………………………………………………………… 
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* or right click on the Sheet tab, select Insert option, select worksheet option, 

finally select OK button. Then new sheet will be insert. 

* Or Click on  +  sign present just after the sheet tabs. 
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or 

Right click 

on the sheet 

tab which we 

want to 

rename 

 
 

…………………………………………………………………………………………………………………………………………. 

 
Data in Sheet1 renamed as 

Tiger Census 
 
 
 
 
 
 
 
 

 
Data in Sheet2 renamed as Number of Tigers 
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…………………………………………………………………………………………………………………………………………….. 
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……………………………………………………………………………………………………………………………………….. 
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Type the data in Sheet1 as follows 
 

Select Sheet2, and keep the cell pointer in a cell, where you want give hyperlink, ( in that cell 

you can write any thing, for example here we wrote Address. 

Select Insert tab, then click on Hyperlink icon, 
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Then displays a Insert Hyperlink dialog box, 

In Text to display a word Amount is automatically selected, In 

Type the cell reference A1 is automatically selected. 

In Cell Reference select Sheet1 because we want create hyperlink to Sheet1 

Select OK  button. 
 

Then,  Amount word colour changes to Blue with underline. 
 

Then, click on word Amount, then we automatically jumped to cell A1 of Sheet1. 
 

……………………………………………………………………………………………………………………………………………. 
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……………………………………………………………………………………………………………………………………………… 
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…………………………………………………………………………………………………………………………………………. 

Linking to external data 

[i] Create new document: It creates a hyperlink to create a new document. 

[ii] In the text to display textbox, specify the text to be displayed as a link. 

[iii] Specify the name for the new workbook, in the name document section. 

[iv] You can also choose whether the document is to be edited now or later by 

choosing the respective radio buttons. 

[v] Click on OK button to insert the link. 
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…………………………………………………………………………………………………………………………………………. 
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…………………………………………………………………………………………………………………………………………. 

Importing data from external data sources: 

In excel, you can insert data in a spreadsheet from different external sources, such as 

from Ms access, web, text other source ( sql server and XML data import ). When you import data, 

you make a permanent connection that can be refreshed, whenever required. 

 Open the excel worksheet in which data is to be inserted from an external source. 

 Open the data tab and choose the from access option from the get external data group. 

 The select data source dialog box opens choose a database file and click on open. 

 The select table dialog box open, Choose the desired table. 

 The import data dialog box opens. 

 Choose the table option to view data in a tabular format also, choose whether you want 

to put the data in the existing worksheet or in a new worksheet. Click on OK 

 The access is displayed in the worksheet. 

 The data can be searched and sorted using the filters displayed along with the fields. 

 The data can be formatted using the various option available in the design tab. 
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B. Fill in the blanks. 

1. Linking spreadsheet data enables you to keep information updated without editing multiple 

locations every time the data changes. 

2. To insert a new worksheet, click on the Home tab and select the Insert Sheet option. 

3. You need to type Reference manually, if you entering it using the keyboard. 

4. A Hyperlink is a coloured and underline text or grphic. 

5. A Relative Hyperlink is a partial address. 
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Chapter-08 
Sharing & Reviewing a Spreadsheet 
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……………………………………………………………………………………………………………………………………………………. 

Practical of Setting up a spreadsheet for sharing: 
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Practical of Recording changes: 
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……………………………………………………………………………………………………………………………………………… 
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…………………………………………………………………………………………………………………………………………………… 

Comparing and Merging Workbook: 
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…………………………………………………………………………………………………………………………………………………. 
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………………………………………………………………………………………………………………………………………………….. 
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3. What are comments ? 

Ans: In a spreadsheet, comments help in providing some extra information on the data 

stored in a cell. 

They play an important role to add some facts, tips, or feedback for user. 
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……………………………………………………………………………………………………………………………………………………….. 
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Select View tab, Select Macros icon, Select Record Macros 

Enter Macro name, shortcut key, store macro in, description as per our need 
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* To check our macro is working or not, select sheet2 ( same data as in sheet1 ) 

* Then Select View Tab, Select Macro Icon, Select View Macro option 

Click on  View Macros option, then select Run  button 

 
 

 

 

 

 

Do the formatting as we want, enter sum formula for Total, 

Then, Select View Tab, Select Macro Icon, Select Stop Recording option 
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…………………………………………………………………………………………………………………………………………………………. 

 

Then output is follows, it means our macro is running…. 
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Select Developer tab, select Visual basic icon from code group 
 

 

 
 

 

Select Visual basic icon, select Module from Insert 
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…………………………………………………………………………………………………………………………………………………………. 
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…………………………………………………………………………………………………………………………………………………… 

Assessment Time: 
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Q(B) Fill in the blanks: 
{ hint : Name, Parameters, Macros, Keystrokes, Function } 

 
[1] ....................... automates the recorded actions and saves your time and efforts. 

[2] You are actually recording your mouse clicks and ...................... while entering a macro. 

[3] A ...................... is a line of code that executes when you call it. 

[4] Each function has a …………………. and may have ………………………………… 

Ans : [1] Macro [2] Keystrokes [3] function [4] Name, Parameters 

Q(C) Answer the following questions 

Q[1] What is a macro ? 

Ans: A macro (which stands for “macro instruction”) is a programmable pattern which translates 

a certain sequence of input into a preset sequence of output. Macros can make tasks less 

repetitive by representing a complicated sequence of keystroke, mouse movements, 

commands, or other types of input. 
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UNIT-3 RELATIONAL DATABASE 

MANAGEMENT SYSTEMS 

 
SESSION 1: APPRECIATE THE CONCEPT OF DATABASE MANAGEMENT SYSTEM 

 

A database is an organized collection of data. It is considered as a container of 
information. 
 

Database Management System: 

 
A database management system is a software package with computer programs that 
controls the creation, maintenance, and use of a database. For example Oracle, IBM 
DB2control, Microsoft SQL Server, Microsoft Access, MySQL, and SQLite. 
 

Data can be organized into two types: 

 

1. Flat File: Data is stored in a single table. Usually suitable for less amount 
of data. 

 

2. Relational: Data is stored in multiple tables and the tables are linked 
using a common field. Relational is suitable for medium to large amount 
of data. 

 

Database Servers : 

 
Database servers are dedicated computers that hold the actual databases and run 
only the DBMS and related software. 

Advantages of Database: 

1) Reduces Data Redundancy : 
2) Sharing of Data : 

3) Data Integrity : 
4) Data Security : 

5. Privacy: 

6. Backup and Recovery: 
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Important Terms : 

 

1) Primary Key: A primary key is a unique value that identifies a row in a table. It 
helps the database to search for a record. 

2) Composite Primary Key: When primary key constraint is applied on one or 
more columns then it is known as Composite Primary Key. 

3) Foreign key: The foreign key identifies a column or set of columns in one 
(referencing) table that refers to a column or set of columns in another 
(referenced) table. 

 

SESSION-2 : CREATING DATABASE AND TABLES 

 

DATABASE OBJECTS: 

 

1) Table: A table is a set of data elements (values) that is organized using a model 
of vertical columns and horizontal rows. 

2) Columns or Fields or Attributes: A column is a set of data values of a 
particular simple type, one for each row of the table. 

3) Rows or Records or Tuples: A row also called a Record or Tuple represents a 
single data item in a table. Every row in the table has the same structure. 
 

Queries: Queries are commands that are used to define the data structure and also 

to manipulate the data in the database. 

There are two types of languages:- 

1. DDL (Data Definition Language) 

2. DML (Data Manipulation Language) 
 

Common DDL Statements are:- 

1. Create: - Used to create database or tables. 

2. Alter: - Used to modify structure of table. 

3. Drop: - Used to delete database objects. 
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Common DML Statements are:- 

 

1. SELECT: - Used to retrieves information from the database. 

2. INSERT: - Used to insert new record into the database. 

3. DELETE: - Used for deletion of information in the database. 

4. UPDATE: - Used for modification of information in the database. 
 

Select Statement: 

 
A SELECT statement retrieves zero or more rows from one or more tables. 
SELECT is the most commonly used Data Manipulation Language (DML) command. To 
retrieve all the columns in a table the syntax is: SELECT * FROM <Table Name>; 

For example, if you want to display all the data from table emp – 
 

Select * from emp; 

The SELECT statement has many optional clauses: 

1. WHERE specifies which rows to retrieve. 

2. ORDER BY specifies an order in which to return the rows. for 

example : Select * from emp where name = “Ravi”; 

SELECT DISTINCT 

 
The SELECT DISTINCT statement is used to return only distinct (different) values. 

For example- 

SELECT DISTINCT Country FROM Customers; 
 

 

Update Statement: 

 
Update statement is used for modifying records in a database. The general syntax 

of the update statement is as follows: 
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UPDATE <table name> SET <Column name > = value [WHERE 

<Condition>]; for 

example : 

1) To increase(update) the salary of employee “Ravi” by Rs 2000 (in table 
Employee)then the SQL command will be: 

Update Employee set Salary = Salary + 2000 Where FirstName = “Ravi”; 
 

INSERT COMMAND IN SQL 

 
INSERT INTO table_name (column1, column2, column3, ...) 

VALUES (value1, value2, value3, ...); 

 

CREATE COMMAND 

 
CREATE TABLE table_name ( 

column1 datatype, 

column2 datatype, 

column3 datatype, 

.... 

); 

 
PRIMARY KEY Constraint 

 

The PRIMARY KEY constraint uniquely identifies each record in a 
table. 

 
CREATE TABLE Persons ( 

ID int NOT NULL, 

LastName varchar(255) NOT NULL, 

FirstName varchar(255), 

Age int, 

PRIMARY KEY (ID) 

); 
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FOREIGN KEY Constraint 

 
The FOREIGN KEY constraint is used to prevent actions that would destroy 

links between tables. 

 

CREATE TABLE Orders ( 
OrderID int NOT NULL, 
OrderNumber int NOT NULL, 
PersonID int, 
PRIMARY KEY (OrderID), 
FOREIGN KEY (PersonID) REFERENCES Persons(PersonID) 

); 

 
 NOT NULL Constraint 
 

 
By default, a column can hold NULL values. 

 
The NOT NULL constraint enforces a column to NOT accept NULL values. 

 

CREATE TABLE Persons ( 
ID int NOT NULL, 
LastName varchar(255) NOT NULL, 
FirstName varchar(255) NOT NULL, 
Age int 

); 

ALTER TABLE Statement 

 

The ALTER TABLE statement is used to add, delete, or modify columns in an 

existing table. 

 
ALTER TABLE table_name ADD column_name datatype; 

ALTER TABLE Customers ADD Email varchar(255); 
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UNIQUE Constraint 
The UNIQUE constraint ensures that all values in a column are different. 

 

CREATE TABLE Persons ( 
ID int NOT NULL UNIQUE, 
LastName varchar(255) NOT NULL, 
FirstName varchar(255), 
Age int 

); 

SQL Working With Dates 

 DATE - Format YYYY-MM-DD 

 DATETIME - Format: YYYY-MM-DD HH:MI:SS 

 TIMESTAMP - Format: YYYY-MM-DD HH:MI:SS 

 YEAR - Format YYYY or YY 

 DATE - Format YYYY-MM-DD 

 DATETIME - Format: YYYY-MM-DD HH:MI:SS 

 SMALLDATETIME - Format: YYYY-MM-DD HH:MI:SS 

 TIMESTAMP - Format: a unique number 

 
SESSION 5: CREATE FORMS AND REPORTS USING WIZARD 

 
FORM: A form provides the user a systematic way of storing information into the 
database. It is an interface in a user specified layout that lets users to view, enter, 
and change data directly in database objects such as tables. 

Creating Form Using Wizard : Steps To Create Form Using Wizard are : 

 
1) Click Use Wizard to Create Form… option under Tasks group. The Form Wizard 
dialog box appears. 

2) Select selective fields to be sent onto the form by selecting the field name 
and clicking >button and click Next. 
 

3) Select the option Add Subform if you need to insert the contents in the table in a 
separate form and click Next. 
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4) Arrange selected fields in a form and click Next. 

5) Select the data entry mode and click Next. 

6) Specify the styles to be used in the form and click Next. 

7) Specify the name of the form. Click Finish. 
 
REPORT : A report helps to display the data in a summarized manner. It is used to generate the overall 
work outcome in a clear format. 

Creating Reports using wizard : Steps To Create Report Using Wizard are : 

 
1) Click on Use Wizard to Create Report… option available under Tasks. 

2) Select all the table fields by selecting the >> button. 

3) Redefine the label of the fields in the reports or else you can set the default name and click 
Next. 

4) Define grouping for the fields of the table if required and click Next 

5) Sort the field in the report by selecting the appropriate field name and sorting method(if required) 
and click Next. 

6) Select the layout of the report and click Next. 

7) Define a name for the report and click Finish. 
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